Error installing chat service

Jul 6, 2011 at 7:54 AM
Edited Jul 6, 2011 at 7:55 AM

When installing the chat service on my back end server (brand new Windows 2008 R2 server) I get an error!

c:\Windows\Microsoft.NET\Framework\v2.0.50727>installutil "C:\Services\ChatService\LI.Kernel.Chat.LPChatService.exe"Microsoft (R) .NET Framework Installation utility Version 2.0.50727.4927Copyright (c) Microsoft Corporation.  All rights reserved.
Exception occurred while initializing the installation:System.BadImageFormatException: Could not load file or assembly 'LI.Kernel.Chat.LPChatService, Version=2.1.4120.38587, Culture=neutral, PublicKeyToken=null' orone of its dependencies. An attempt was made to load a program with an incorrect format..

I have checked and re-checked the documentation and can confirm that .net 4 is installed, my .net 3.5.1 features are exactly the same as shown in the documentation and I have installed the Lync core as well as UCMA 3.0 runtime. All other services have installed fine it is just the chat service I am struggling with.

Has anybody seen this error before? any help would be greatly appreciated!

Thanks

James

Coordinator
Jul 6, 2011 at 8:16 AM

Hi James,

The chatservice needs to be installed using the "framework64" path.

From the rudimentary documentation (see the text marked with bold):

  • ·         for AD Search Service, AD Authentication Service, AD PhotoToSQLService and Calendar service is : c:\Windows\Microsoft.NET\Framework\v2.0.50727
  • ·         For Chat Service: C:\Windows\Microsoft.NET\Framework64\v2.0.50727
  • ·         For Live data Service: C:\Windows\Microsoft.NET\Framework\v4.0.30319

Thanks,

Mikkel

 

 

Jul 6, 2011 at 1:28 PM

I feel like such a fool!!! I must have gone over that section 10 times over and not seen that tiny tiny difference!! I knew it was an x32/x64 issue just forgot about using the framework64 folder.

works like a treat now, thanks for your help

James